CVE-2025-3760
Description
A stored cross-site scripting (XSS) vulnerability exists with radio button type custom fields in Liferay Portal 7.2.0 through 7.4.3.129, and Liferay DXP 2024.Q4.1 through 2024.Q4.7, 2024.Q3.1 through 2024.Q3.9, 2024.Q2.0 through 2024.Q2.13, 2024.Q1.1 through 2024.Q1.12, 2023.Q4.0 through 2023.Q4.10, 2023.Q3.1 through 2023.Q3.10, 7.4 GA through update 92, 7.3 GA through update 36, and 7.2 GA through fix pack 20 allows remote authenticated attackers to inject malicious JavaScript into a page.
How to fix
- liferay digital_experience_platform2024.Q1.13, 2024.q3.10, 2025.q1.0 or later
- com.liferay.portal:release.portal.bom7.4.3.132 or later
- com.liferay.portal:release.dxp.bom2024.Q1.13, 2024.Q3.10, 2025.Q1.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| liferay liferay_portal | 7.2.0 ≤ v ≤ 7.4.3.129 | — |
| liferay digital_experience_platform | 7.2 ≤ v ≤ 7.4, 2023.Q3.0 ≤ v < 2024.Q1.13, 2024.q2.0 ≤ v < 2024.q3.10, 2024.Q4.0 ≤ v < 2025.q1.0 | 2024.Q1.13, 2024.q3.10, 2025.q1.0 |
| com.liferay.portal:release.portal.bomMaven | 7.2.0 ≤ v < 7.4.3.132 | 7.4.3.132 |
| com.liferay.portal:release.dxp.bomMaven | 7.2.10.fp1 ≤ v ≤ 7.2.10.fp20, 7.3.10.ep1 ≤ v ≤ 7.3.10.u36, 7.4.13.u1 ≤ v ≤ 7.4.13.u92, 2023.Q3.1 ≤ v ≤ 2023.Q3.10, 2023.Q4.0 ≤ v ≤ 2023.Q4.10, 2024.Q1.1 ≤ v < 2024.Q1.13, 2024.Q2.0 ≤ v ≤ 2024.Q2.13, 2024.Q3.1 ≤ v < 2024.Q3.10, 2024.Q4.1 ≤ v < 2025.Q1.0, 7.2.10 ≤ v ≤ 7.2.10.8, 7.3.10.0 ≤ v ≤ 7.3.10.3, No range specified | 2024.Q1.13, 2024.Q3.10, 2025.Q1.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.