CVE-2025-3928
Description
Commvault Web Server has an unspecified vulnerability that can be exploited by a remote, authenticated attacker. According to the Commvault advisory: "Webservers can be compromised through bad actors creating and executing webshells." Fixed in version 11.36.46, 11.32.89, 11.28.141, and 11.20.217 for Windows and Linux platforms. This vulnerability was added to the CISA Known Exploited Vulnerabilities (KEV) Catalog on 2025-04-28.
How to fix
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
CISA due date: May 19, 2025- commvault commvault11.20.217, 11.28.141, 11.32.89, 11.36.46 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| commvault commvault | 11.20.0 ≤ v < 11.20.217, 11.28.0 ≤ v < 11.28.141, 11.32.0 ≤ v < 11.32.89, 11.36.0 ≤ v < 11.36.46 | 11.20.217, 11.28.141, 11.32.89, 11.36.46 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.