CVE-2025-4102

High

Description

The Beaver Builder Plugin (Starter Version) plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'save_enabled_icons' function in all versions up to, and including, 2.9.1. This makes it possible for authenticated attackers, with Administrator-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. The vulnerability was partially patched in version 2.9.1.

SeverityHigh
CVSS7.2
Exploit probability—
ProductFastlinemedia Beaver Builder
PublishedJun 20, 2025
First seenJun 20, 2025

How to fix

Update
  • fastlinemedia beaver_builder2.9.1.1 or later

Affected products

ProductAffected versionsFixed in
fastlinemedia beaver_builderv < 2.9.1.12.9.1.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-4102 · Fastlinemedia Beaver Builder · Dark Radar