CVE-2025-4210

High

Description

A vulnerability classified as critical was found in Casdoor up to 1.811.0. This vulnerability affects the function HandleScim of the file controllers/scim.go of the component SCIM User Creation Endpoint. The manipulation leads to authorization bypass. The attack can be initiated remotely. Upgrading to version 1.812.0 is able to address this issue. The name of the patch is 3d12ac8dc2282369296c3386815c00a06c6a92fe. It is recommended to upgrade the affected component.

SeverityHigh
CVSS7.3
Exploit probability79. percentile1.8%
ProductGithub.com/casdoor/casdoor
PublishedMay 2, 2025
First seenMay 2, 2025

How to fix

Affected products

ProductAffected versionsFixed in
github.com/casdoor/casdoorGov < 1.812.0, No range specified1.812.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.