CVE-2025-43794
Description
Stored cross-site scripting (XSS) vulnerability in Liferay Portal 7.4.0 through 7.4.3.111, and older unsupported versions, and Liferay DXP 2023.Q4.0, 2023.Q3.1 through 2023.Q3.4, 7.4 GA through update 92, 7.3 GA through update 35, and older unsupported versions allows remote authenticated attackers with the instance administrator role to inject arbitrary web script or HTML into all pages via a crafted payload injected into the Instance Configuration's (1) CDN Host HTTP text field or (2) CDN Host HTTPS text field.
How to fix
- liferay liferay_portal7.4.3.112 or later
- liferay digital_experience_platform7.3, 2023.q3.5 or later
- com.liferay.portal:com.liferay.portal.impl99.0.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| liferay liferay_portal | v < 7.4.3.112 | 7.4.3.112 |
| liferay digital_experience_platform | v < 7.3, 2023.q3.1 ≤ v < 2023.q3.5, 7.3, 7.4, 2023.q4.0 | 7.3, 2023.q3.5 |
| com.liferay.portal:com.liferay.portal.implMaven | v < 99.0.0 | 99.0.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.