CVE-2025-4565
Description
Any project that uses Protobuf Pure-Python backend to parse untrusted Protocol Buffers data containing an arbitrary number of recursive groups, recursive messages or a series of SGROUP tags can be corrupted by exceeding the Python recursion limit. This can result in a Denial of service by crashing the application with a RecursionError. We recommend upgrading to version =>6.31.1 or beyond commit 17838beda2943d08b8a9d4df5b68f5f04f26d901
How to fix
- protobuf4.25.8, 5.29.5, 6.31.1 or later
- google protobuf-python4.25.8, 5.29.5, 6.31.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| protobufPyPI | v < 4.25.8, 5.26.0rc1 ≤ v < 5.29.5, 6.30.0rc1 ≤ v < 6.31.1 | 4.25.8, 5.29.5, 6.31.1 |
| google protobuf-python | v < 4.25.8, 5.26.0 ≤ v < 5.29.5, 6.30.0 ≤ v < 6.31.1 | 4.25.8, 5.29.5, 6.31.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.