CVE-2025-46338

Medium

Description

Audiobookshelf is a self-hosted audiobook and podcast server. Prior to version 2.21.0, an improper input handling vulnerability in the `/api/upload` endpoint allows an attacker to perform a reflected cross-site scripting (XSS) attack by submitting malicious payloads in the `libraryId` field. The unsanitized input is reflected in the server’s error message, enabling arbitrary JavaScript execution in a victim's browser. This issue has been patched in version 2.21.0.

SeverityMedium
CVSS6.1
Exploit probability—
ProductAudiobookshelf
PublishedApr 29, 2025
First seenApr 29, 2025

How to fix

Update
  • audiobookshelf audiobookshelf2.21.0 or later

Affected products

ProductAffected versionsFixed in
audiobookshelf audiobookshelfv < 2.21.02.21.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.