CVE-2025-46346

Medium

Description

YesWiki is a wiki system written in PHP. Prior to version 4.5.4, a stored cross-site scripting (XSS) vulnerability was discovered in the application’s comments feature. This issue allows a malicious actor to inject JavaScript payloads that are stored and later executed in the browser of any user viewing the affected comment. The XSS occurs because the application fails to properly sanitize or encode user input submitted to the comments. Notably, the application sanitizes or does not allow execution of `<script>` tags, but does not account for payloads obfuscated using JavaScript block comments like `/* JavaScriptPayload */`. This issue has been patched in version 4.5.4.

SeverityMedium
CVSS5.4
Exploit probability—
ProductYeswiki
PublishedApr 29, 2025
First seenApr 29, 2025

How to fix

Update
  • yeswiki yeswiki4.5.4 or later
  • yeswiki/yeswiki4.5.4 or later

Affected products

ProductAffected versionsFixed in
yeswiki yeswikiv < 4.5.44.5.4
yeswiki/yeswikiPackagistv < 4.5.44.5.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.