CVE-2025-46349
High
Description
YesWiki is a wiki system written in PHP. Prior to version 4.5.4, YesWiki is vulnerable to reflected XSS in the file upload form. This vulnerability allows any malicious unauthenticated user to create a link that can be clicked on by the victim to perform arbitrary actions. This issue has been patched in version 4.5.4.
SeverityHigh
CVSS7.6
Exploit probability—
Product
Yeswiki
PublishedApr 29, 2025
First seenApr 29, 2025
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- yeswiki yeswiki4.5.4 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| yeswiki yeswiki | v < 4.5.4 | 4.5.4 |
| yeswiki/yeswikiPackagist | v ≤ 4.5.3 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.