CVE-2025-46548
Description
If you enable Basic Authentication in Pekko Management using the Java DSL, the authenticator may not be properly applied. Users that rely on authentication instead of making sure the Management API ports are only available to trusted users are recommended to upgrade to version 1.1.1, which fixes this issue. Akka was affected by the same issue and has released the fix in version 1.6.1.
How to fix
- akka akka_management1.6.1 or later
- org.apache.pekko:pekko-management_2.121.1.1 or later
- com.lightbend.akka.management:akka-management_2.131.6.1 or later
- org.apache.pekko:pekko-management_2.131.1.1 or later
- org.apache.pekko:pekko-management_31.1.1 or later
- com.lightbend.akka.management:akka-management_2.121.6.1 or later
- com.lightbend.akka.management:akka-management_31.6.1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache pekko_management | 1.0.0 ≤ v ≤ 1.1.1 | — |
| akka akka_management | v < 1.6.1 | 1.6.1 |
| org.apache.pekko:pekko-management_2.12Maven | v < 1.1.1 | 1.1.1 |
| com.lightbend.akka.management:akka-management_2.13Maven | v < 1.6.1 | 1.6.1 |
| org.apache.pekko:pekko-management_2.13Maven | v < 1.1.1 | 1.1.1 |
| org.apache.pekko:pekko-management_3Maven | v < 1.1.1 | 1.1.1 |
| com.lightbend.akka.management:akka-management_2.12Maven | v < 1.6.1 | 1.6.1 |
| com.lightbend.akka.management:akka-management_3Maven | v < 1.6.1 | 1.6.1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.