CVE-2025-46560

Medium

Description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.8.0 and prior to 0.8.5 are affected by a critical performance vulnerability in the input preprocessing logic of the multimodal tokenizer. The code dynamically replaces placeholder tokens (e.g., <|audio_|>, <|image_|>) with repeated tokens based on precomputed lengths. Due to ​​inefficient list concatenation operations​​, the algorithm exhibits ​​quadratic time complexity (O(n²))​​, allowing malicious actors to trigger resource exhaustion via specially crafted inputs. This issue has been patched in version 0.8.5.

SeverityMedium
CVSS6.5
Exploit probability—
ProductVllm
PublishedApr 30, 2025
First seenApr 30, 2025
Weakness typeCWE-1333CWE-1333

How to fix

Update
  • vllm vllm0.8.5 or later
  • vllm0.8.5 or later

Affected products

ProductAffected versionsFixed in
vllm vllm0.8.0 ≤ v < 0.8.50.8.5
vllmPyPI0.8.0 ≤ v < 0.8.50.8.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.