CVE-2025-46647

Medium

Description

A vulnerability of plugin openid-connect in Apache APISIX. This vulnerability will only have an impact if all of the following conditions are met: 1. Use the openid-connect plugin with introspection mode 2. The auth service connected to openid-connect provides services to multiple issuers 3. Multiple issuers share the same private key and relies only on the issuer being different If affected by this vulnerability, it would allow an attacker with a valid account on one of the issuers to log into the other issuer. This issue affects Apache APISIX: until 3.12.0. Users are recommended to upgrade to version 3.12.0 or higher.

SeverityMedium
CVSS5.3
Exploit probability—
ProductApache Apisix
PublishedJul 2, 2025
First seenJul 2, 2025
Weakness typeCWE-302CWE-302

How to fix

Update
  • apache apisix3.12.0 or later

Affected products

ProductAffected versionsFixed in
apache apisixv < 3.12.03.12.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.