CVE-2025-46701

High

Description

Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.

SeverityHigh
CVSS7.3
Exploit probability—
ProductApache Tomcat
PublishedMay 29, 2025
First seenMay 29, 2025
Weakness typeCWE-178CWE-178

How to fix

Update
  • apache tomcat9.0.105, 10.1.41, 11.0.7 or later
  • org.apache.tomcat:tomcat-catalina9.0.105, 10.1.41, 11.0.7 or later
  • org.apache.tomcat.embed:tomcat-embed-core9.0.105, 10.1.41, 11.0.7 or later

Affected products

ProductAffected versionsFixed in
apache tomcat9.0.0 ≤ v < 9.0.105, 10.1.0 ≤ v < 10.1.41, 11.0.0 ≤ v < 11.0.79.0.105, 10.1.41, 11.0.7
org.apache.tomcat:tomcat-catalinaMaven9.0.0.M1 ≤ v < 9.0.105, 10.1.0-M1 ≤ v < 10.1.41, 11.0.0-M1 ≤ v < 11.0.7, 8.5.0 ≤ v ≤ 8.5.1009.0.105, 10.1.41, 11.0.7
org.apache.tomcat.embed:tomcat-embed-coreMaven9.0.0.M1 ≤ v < 9.0.105, 10.1.0-M1 ≤ v < 10.1.41, 11.0.0-M1 ≤ v < 11.0.7, 8.5.0 ≤ v ≤ 8.5.1009.0.105, 10.1.41, 11.0.7

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.