CVE-2025-46731
Description
Craft is a content management system. Versions of Craft CMS on the 4.x branch prior to 4.14.13 and on the 5.x branch prior to 5.6.16 contains a potential remote code execution vulnerability via Twig SSTI. One must have administrator access and `ALLOW_ADMIN_CHANGES` must be enabled for this to work. Users should update to the patched versions 4.14.13 or 5.6.15 to mitigate the issue.
How to fix
- craftcms craft_cms4.14.13, 5.6.15 or later
- craftcms/cms4.14.13, 5.6.15 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| craftcms craft_cms | 4.1.0 ≤ v < 4.14.13, 5.1.0 ≤ v < 5.6.15, 4.0.0, 5.0.0 | 4.14.13, 5.6.15 |
| craftcms/cmsPackagist | 4.0.0-RC1 ≤ v < 4.14.13, 5.0.0-RC1 ≤ v < 5.6.15 | 4.14.13, 5.6.15 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.