CVE-2025-46812

Low

Description

Trix is a what-you-see-is-what-you-get rich text editor for everyday writing. Versions prior to 2.1.15 are vulnerable to XSS attacks when pasting malicious code. An attacker could trick a user to copy and paste malicious code that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. This issue has been patched in version 2.1.15.

SeverityLow
CVSS2.0
Exploit probability—
ProductTrix
PublishedMay 8, 2025
First seenMay 8, 2025

How to fix

Update
  • trix2.1.15 or later

Affected products

ProductAffected versionsFixed in
trixnpmv < 2.1.152.1.15

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.