CVE-2025-46814

Low

Description

FastAPI Guard is a security library for FastAPI that provides middleware to control IPs, log requests, and detect penetration attempts. An HTTP header injection vulnerability has been identified in versions prior to 2.0.0. By manipulating the X-Forwarded-For header, an attacker can potentially inject arbitrary IP addresses into the request. This vulnerability can allow attackers to bypass IP-based access controls, mislead logging systems, and impersonate trusted clients. It is especially impactful when the application relies on the X-Forwarded-For header for IP-based authorization or authentication. Users should upgrade to FastAPI Guard version 2.0.0 to receive a fix.

SeverityLow
CVSS3.4
Exploit probability—
ProductFastapi-guard Fastapi Guard
PublishedMay 6, 2025
First seenMay 6, 2025
Weakness typeCWE-74Injection

How to fix

Update
  • fastapi-guard fastapi_guard2.0.0 or later
  • fastapi-guard2.0.0 or later

Affected products

ProductAffected versionsFixed in
fastapi-guard fastapi_guardv < 2.0.02.0.0
fastapi-guardPyPIv < 2.0.02.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.