CVE-2025-46817

High

Description

Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.

SeverityHigh
CVSS7.0
Exploit probability90. percentile3.9%
ProductRedis
PublishedOct 3, 2025
First seenOct 3, 2025

How to fix

Update
  • redis redis6.2.20, 7.2.11, 7.4.6, 8.0.4, 8.2.2 or later

Affected products

ProductAffected versionsFixed in
redis redisv < 6.2.20, 7.0 ≤ v < 7.2.11, 7.4.0 ≤ v < 7.4.6, 8.0.0 ≤ v < 8.0.4, 8.2.0 ≤ v < 8.2.26.2.20, 7.2.11, 7.4.6, 8.0.4, 8.2.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-46817 · Redis · Dark Radar