CVE-2025-47279
Description
Undici is an HTTP/1.1 client for Node.js. Prior to versions 5.29.0, 6.21.2, and 7.5.0, applications that use undici to implement a webhook-like system are vulnerable. If the attacker set up a server with an invalid certificate, and they can force the application to call the webhook repeatedly, then they can cause a memory leak. This has been patched in versions 5.29.0, 6.21.2, and 7.5.0. As a workaound, avoid calling a webhook repeatedly if the webhook fails.
How to fix
- undici5.29.0, 6.21.2, 7.5.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| undicinpm | v < 5.29.0, 6.0.0 ≤ v < 6.21.2, 7.0.0 ≤ v < 7.5.0 | 5.29.0, 6.21.2, 7.5.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.