CVE-2025-47291

High

Description

containerd is an open-source container runtime. A bug was found in the containerd's CRI implementation where containerd, starting in version 2.0.1 and prior to version 2.0.5, doesn't put usernamespaced containers under the Kubernetes' cgroup hierarchy, therefore some Kubernetes limits are not honored. This may cause a denial of service of the Kubernetes node. This bug has been fixed in containerd 2.0.5+ and 2.1.0+. Users should update to these versions to resolve the issue. As a workaround, disable usernamespaced pods in Kubernetes temporarily.

SeverityHigh
CVSS7.5
Exploit probability—
ProductLinuxfoundation Containerd
PublishedMay 21, 2025
First seenMay 21, 2025
Weakness typeCWE-266CWE-266

How to fix

Update
  • linuxfoundation containerd2.0.5 or later
  • github.com/containerd/containerd/v22.0.5 or later

Affected products

ProductAffected versionsFixed in
linuxfoundation containerd2.0.1 ≤ v < 2.0.52.0.5
github.com/containerd/containerd/v2Go2.0.1 ≤ v < 2.0.52.0.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.