CVE-2025-47410
Description
Apache Geode is vulnerable to CSRF attacks through GET requests to the Management and Monitoring REST API that could allow an attacker who has tricked a user into giving up their Geode session credentials to submit malicious commands on the target system on behalf of the authenticated user. This issue affects Apache Geode: versions 1.10 through 1.15.1 Users are recommended to upgrade to version 1.15.2, which fixes the issue.
How to fix
- apache geode1.15.2 or later
- org.apache.geode:geode-web1.15.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache geode | 1.10.0 ≤ v < 1.15.2 | 1.15.2 |
| org.apache.geode:geode-webMaven | 1.10.0 ≤ v < 1.15.2 | 1.15.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.