CVE-2025-47935

High

Description

Multer is a node.js middleware for handling `multipart/form-data`. Versions prior to 2.0.0 are vulnerable to a resource exhaustion and memory leak issue due to improper stream handling. When the HTTP request stream emits an error, the internal `busboy` stream is not closed, violating Node.js stream safety guidance. This leads to unclosed streams accumulating over time, consuming memory and file descriptors. Under sustained or repeated failure conditions, this can result in denial of service, requiring manual server restarts to recover. All users of Multer handling file uploads are potentially impacted. Users should upgrade to 2.0.0 to receive a patch. No known workarounds are available.

SeverityHigh
CVSS7.5
Exploit probability—
ProductMulter
PublishedMay 19, 2025
First seenMay 19, 2025
Weakness typeCWE-401CWE-401

How to fix

Update
  • multer2.0.0 or later

Affected products

ProductAffected versionsFixed in
multernpmv < 2.0.02.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.