CVE-2025-47936
Description
TYPO3 is an open source, PHP based web content management system. In versions on the 12.x branch prior to 12.4.31 LTS and the 13.x branch prior to 13.4.2 LTS, Webhooks are inherently vulnerable to Cross-Site Request Forgery (CSRF), which can be exploited by adversaries to target internal resources (e.g., localhost or other services on the local network). While this is not a vulnerability in TYPO3 itself, it may enable attackers to blindly access systems that would otherwise be inaccessible. An administrator-level backend user account is required to exploit this vulnerability. Users should update to TYPO3 version 12.4.31 LTS or 13.4.12 LTS to fix the problem.
How to fix
- typo3 typo312.4.31, 13.4.12 or later
- typo3/cms-webhooks12.4.31, 13.4.12 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| typo3 typo3 | 12.0.0 ≤ v < 12.4.31, 13.0.0 ≤ v < 13.4.12 | 12.4.31, 13.4.12 |
| typo3/cms-webhooksPackagist | 12.0.0 ≤ v < 12.4.31, 13.0.0 ≤ v < 13.4.12 | 12.4.31, 13.4.12 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.