CVE-2025-47940

High

Description

TYPO3 is an open source, PHP based web content management system. Starting in version 10.0.0 and prior to versions 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, administrator-level backend users without system maintainer privileges can escalate their privileges and gain system maintainer access. Exploiting this vulnerability requires a valid administrator account. Users should update to TYPO3 version 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.

SeverityHigh
CVSS7.2
Exploit probability—
ProductTypo3
PublishedMay 20, 2025
First seenMay 20, 2025
Weakness typeCWE-283CWE-283

How to fix

Update
  • typo3 typo310.4.50, 11.5.44, 12.4.31, 13.4.12 or later
  • typo3/cms-core10.4.50, 11.5.44, 12.4.31, 13.4.12 or later

Affected products

ProductAffected versionsFixed in
typo3 typo310.4.0 ≤ v < 10.4.50, 11.0.0 ≤ v < 11.5.44, 12.0.0 ≤ v < 12.4.31, 13.0.0 ≤ v < 13.4.1210.4.50, 11.5.44, 12.4.31, 13.4.12
typo3/cms-corePackagist10.4.0 ≤ v < 10.4.50, 11.0.0 ≤ v < 11.5.44, 12.0.0 ≤ v < 12.4.31, 13.0.0 ≤ v < 13.4.1210.4.50, 11.5.44, 12.4.31, 13.4.12

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.