CVE-2025-47943
Description
Gogs is an open source self-hosted Git service. In application version 0.14.0+dev and prior, there is a stored cross-site scripting (XSS) vulnerability present in Gogs, which allows client-side Javascript code execution. The vulnerability is caused by the usage of a vulnerable and outdated component: pdfjs-1.4.20 under public/plugins/. This issue has been fixed for gogs.io/gogs in version 0.13.3.
How to fix
- gogs.io/gogs0.13.3-0.20250608224432-110117b2e5e5 or later
- github.com/gogs/gogs0.13.3-0.20250608224432-110117b2e5e5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| gogs.io/gogsGo | v < 0.13.3-0.20250608224432-110117b2e5e5 | 0.13.3-0.20250608224432-110117b2e5e5 |
| github.com/gogs/gogsGo | v < 0.13.3-0.20250608224432-110117b2e5e5 | 0.13.3-0.20250608224432-110117b2e5e5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.