CVE-2025-48053

High

Description

Discourse is an open-source discussion platform. Prior to version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch, sending a malicious URL in a PM to a bot user can cause a reduced the availability of a Discourse instance. This issue is patched in version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch. No known workarounds are available.

SeverityHigh
CVSS7.5
Exploit probability—
ProductDiscourse
PublishedJun 9, 2025
First seenJun 9, 2025

How to fix

Update
  • discourse discourse3.4.4, 3.5.0 or later

Affected products

ProductAffected versionsFixed in
discourse discoursev < 3.4.4, v < 3.5.0, 3.5.03.4.4, 3.5.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.