CVE-2025-48068
Description
Next.js is a React framework for building full-stack web applications. In versions starting from 13.0 to before 14.2.30 and 15.0.0 to before 15.2.2, Next.js may have allowed limited source code exposure when the dev server was running with the App Router enabled. The vulnerability only affects local development environments and requires the user to visit a malicious webpage while npm run dev is active. This issue has been patched in versions 14.2.30 and 15.2.2.
How to fix
- vercel next.js14.2.30, 15.2.2 or later
- next15.2.2, 14.2.30 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vercel next.js | 13.0.0 ≤ v < 14.2.30, 15.0.0 ≤ v < 15.2.2 | 14.2.30, 15.2.2 |
| nextnpm | 15.0.0 ≤ v < 15.2.2, 13.0 ≤ v < 14.2.30 | 15.2.2, 14.2.30 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.