CVE-2025-48370

Low

Description

auth-js is an isomorphic Javascript library for Supabase Auth. Prior to version 2.70.0, the library functions getUserById, deleteUser, updateUserById, listFactors and deleteFactor did not require the user supplied values to be valid UUIDs. This could lead to a URL path traversal, resulting in the wrong API function being called. Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. This issue has been patched in version 2.70.0.

SeverityLow
CVSS2.7
Exploit probability—
Product@supabase/auth-js
PublishedMay 27, 2025
First seenMay 27, 2025

How to fix

Update
  • @supabase/auth-js2.70.0 or later

Affected products

ProductAffected versionsFixed in
@supabase/auth-jsnpmv < 2.70.02.70.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.