CVE-2025-48371
Description
OpenFGA is an authorization/permission engine. OpenFGA versions 1.8.0 through 1.8.12 (corresponding to Helm chart openfga-0.2.16 through openfga-0.2.30 and docker 1.8.0 through 1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users are affected under four specific conditions: First, calling Check API or ListObjects with an authorization model that has a relationship directly assignable by both type bound public access and userset; second, there are check or list object queries with contextual tuples for the relationship that can be directly assignable by both type bound public access and userset; third, those contextual tuples’s user field is an userset; and finally, type bound public access tuples are not assigned to the relationship. Users should upgrade to version 1.8.13 to receive a patch. The upgrade is backwards compatible.
How to fix
- openfga helm_charts0.2.32 or later
- openfga openfga1.8.13 or later
- github.com/openfga/openfga1.8.13 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| openfga helm_charts | 0.2.16 ≤ v < 0.2.32 | 0.2.32 |
| openfga openfga | 1.8.0 ≤ v < 1.8.13 | 1.8.13 |
| github.com/openfga/openfgaGo | 1.8.0 ≤ v < 1.8.13 | 1.8.13 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.