CVE-2025-48459

Medium

Description

Deserialization of Untrusted Data vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 1.0.0 before 2.0.5. Users are recommended to upgrade to version 2.0.5, which fixes the issue.

SeverityMedium
CVSS5.3
Exploit probability—
ProductApache Iotdb
PublishedSep 24, 2025
First seenSep 24, 2025

How to fix

Update
  • apache iotdb2.0.5 or later
  • org.apache.iotdb:iotdb-confignode2.0.5 or later
  • apache-iotdb2.0.5 or later

Affected products

ProductAffected versionsFixed in
apache iotdb1.0.0 ≤ v < 2.0.52.0.5
org.apache.iotdb:iotdb-confignodeMaven1.0.0 ≤ v < 2.0.52.0.5
apache-iotdbPyPI1.0.0 ≤ v < 2.0.52.0.5

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.