CVE-2025-48490

Medium

Description

Laravel Rest Api is an API generator. Prior to version 2.13.0, a validation bypass vulnerability was discovered where multiple validations defined for the same attribute could be silently overridden. Due to how the framework merged validation rules across multiple contexts (such as index, store, and update actions), malicious actors could exploit this behavior by crafting requests that bypass expected validation rules, potentially injecting unexpected or dangerous parameters into the application. This could lead to unauthorized data being accepted or processed by the API, depending on the context in which the validation was bypassed. This issue has been patched in version 2.13.0.

SeverityMedium
CVSS6.6
Exploit probability—
ProductLomkit/laravel-rest-api
PublishedMay 30, 2025
First seenMay 30, 2025

How to fix

Update
  • lomkit/laravel-rest-api2.13.0 or later

Affected products

ProductAffected versionsFixed in
lomkit/laravel-rest-apiPackagistv < 2.13.02.13.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.