CVE-2025-48883

Medium

Description

Chrome PHP allows users to start playing with chrome/chromium in headless mode from PHP. Prior to version 1.14.0, CSS Selector expressions are not properly encoded, which can lead to XSS (cross-site scripting) vulnerabilities. This is patched in v1.14.0. As a workaround, users can apply encoding manually to their selectors if they are unable to upgrade.

SeverityMedium
CVSS5.3
Exploit probability—
ProductChrome-php/chrome
PublishedMay 30, 2025
First seenMay 30, 2025

How to fix

Update
  • chrome-php/chrome1.14.0 or later

Affected products

ProductAffected versionsFixed in
chrome-php/chromePackagistv < 1.14.01.14.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.