CVE-2025-48888
Description
Deno is a JavaScript, TypeScript, and WebAssembly runtime. Starting in version 1.41.3 and prior to versions 2.1.13, 2.2.13, and 2.3.2, `deno run --allow-read --deny-read main.ts` results in allowed, even though 'deny' should be stronger. The result is the same with all global unary permissions given as `--allow-* --deny-*`. This only affects a nonsensical combination of flags, so there shouldn't be a real impact on the userbase. Users may upgrade to version 2.1.13, 2.2.13, or 2.3.2 to receive a patch.
How to fix
- deno deno2.1.13, 2.2.13, 2.3.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| deno deno | 1.41.3 ≤ v < 2.1.13, 2.2.0 ≤ v < 2.2.13, 2.3.0 ≤ v < 2.3.2 | 2.1.13, 2.2.13, 2.3.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.