CVE-2025-48912

Medium

Description

An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Superset
PublishedMay 30, 2025
First seenMay 30, 2025
Weakness typeCWE-89SQL injection

How to fix

Update
  • apache superset4.1.2 or later
  • apache-superset4.1.2 or later

Affected products

ProductAffected versionsFixed in
apache supersetv < 4.1.24.1.2
apache-supersetPyPIv < 4.1.24.1.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.