CVE-2025-48913
Critical
Description
If untrusted users are allowed to configure JMS for Apache CXF, previously they could use RMI or LDAP URLs, potentially leading to code execution capabilities. This interface is now restricted to reject those protocols, removing this possibility. Users are recommended to upgrade to versions 3.6.8, 4.0.9 or 4.1.3, which fix this issue.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Apache Cxf
PublishedAug 8, 2025
First seenAug 8, 2025
Weakness typeCWE-20Improper input validation
How to fix
Update
- apache cxf3.6.8, 4.0.9, 4.1.3 or later
- org.apache.cxf:cxf-rt-transports-jms3.6.8, 4.0.9, 4.1.3 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache cxf | v < 3.6.8, 4.0.0 ≤ v < 4.0.9, 4.1.0 ≤ v < 4.1.3 | 3.6.8, 4.0.9, 4.1.3 |
| org.apache.cxf:cxf-rt-transports-jmsMaven | v < 3.6.8, 4.0.0 ≤ v < 4.0.9, 4.1.0 ≤ v < 4.1.3 | 3.6.8, 4.0.9, 4.1.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.