CVE-2025-48957
Description
AstrBot is a large language model chatbot and development framework. A path traversal vulnerability present in versions 3.4.4 through 3.5.12 may lead to information disclosure, such as API keys for LLM providers, account passwords, and other sensitive data. The vulnerability has been addressed in Pull Request #1676 and is included in version 3.5.13. As a workaround, users can edit the `cmd_config.json` file to disable the dashboard feature as a temporary workaround. However, it is strongly recommended to upgrade to version v3.5.13 or later to fully resolve this issue.
How to fix
- astrbot astrbot3.5.13 or later
- astrbot3.5.13 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| astrbot astrbot | 3.4.4 ≤ v < 3.5.13 | 3.5.13 |
| astrbotPyPI | 3.4.4 ≤ v < 3.5.13 | 3.5.13 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.