CVE-2025-48977
Medium
Description
Relative Path Traversal vulnerability in Apache Ignite REST API. Authenticated REST API users can read any file on the server with "cmd=log" command and a log path crafted in a certain way. This issue affects Apache Ignite: from 2.0.0 through 2.17.0. Users are recommended to upgrade to version 2.18.0, which fixes the issue.
SeverityMedium
CVSS6.5
Exploit probability45. percentile0.5%
Product
Apache Ignite
PublishedMay 28, 2026
First seenMay 28, 2026
Weakness typeCWE-23CWE-23
How to fix
Update
- apache ignite2.18.0 or later
- org.apache.ignite:ignite-core2.18.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache ignite | 2.0.0 ≤ v < 2.18.0 | 2.18.0 |
| org.apache.ignite:ignite-coreMaven | 2.0.0 ≤ v < 2.18.0 | 2.18.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.