CVE-2025-48989
Description
Improper Resource Shutdown or Release vulnerability in Apache Tomcat made Tomcat vulnerable to the made you reset attack. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.9, from 10.1.0-M1 through 10.1.43 and from 9.0.0.M1 through 9.0.107. Older, EOL versions may also be affected. Users are recommended to upgrade to one of versions 11.0.10, 10.1.44 or 9.0.108 which fix the issue.
How to fix
- apache tomcat9.0.108, 10.1.44, 11.0.10 or later
- org.apache.tomcat:tomcat-coyote11.0.10, 10.1.44, 9.0.108 or later
- org.apache.tomcat.embed:tomcat-embed-core11.0.10, 10.1.44, 9.0.108 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tomcat | 9.0.1 ≤ v < 9.0.108, 10.0.0 ≤ v < 10.1.44, 11.0.0 ≤ v < 11.0.10, 9.0.0 | 9.0.108, 10.1.44, 11.0.10 |
| org.apache.tomcat:tomcat-coyoteMaven | 11.0.0-M1 ≤ v < 11.0.10, 10.1.0-M1 ≤ v < 10.1.44, 9.0.0.M1 ≤ v < 9.0.108 | 11.0.10, 10.1.44, 9.0.108 |
| org.apache.tomcat.embed:tomcat-embed-coreMaven | 11.0.0-M1 ≤ v < 11.0.10, 10.1.0-M1 ≤ v < 10.1.44, 9.0.0.M1 ≤ v < 9.0.108 | 11.0.10, 10.1.44, 9.0.108 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.