CVE-2025-48997

High

Description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to `2.0.1` to receive a patch. No known workarounds are available.

SeverityHigh
CVSS8.7
Exploit probability—
ProductMulter
PublishedJun 3, 2025
First seenJun 3, 2025
Weakness typeCWE-248CWE-248

How to fix

Update
  • multer2.0.1 or later

Affected products

ProductAffected versionsFixed in
multernpm1.4.4-lts.1 ≤ v < 2.0.12.0.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.