CVE-2025-49130

Medium

Description

Laravel Translation Manager is a package to manage Laravel translation files. Prior to version 0.6.8, the application is vulnerable to Cross-Site Scripting (XSS) attacks due to incorrect input validation and sanitization of user-input data. An attacker can inject arbitrary HTML code, including JavaScript scripts, into the page processed by the user's browser, allowing them to steal sensitive data, hijack user sessions, or conduct other malicious activities. Only authenticated users with access to the translation manager are impacted. The issue is fixed in version 0.6.8.

SeverityMedium
CVSS6.0
Exploit probability—
ProductBarryvdh/laravel-translation-manager
PublishedJun 9, 2025
First seenJun 9, 2025

How to fix

Update
  • barryvdh/laravel-translation-manager0.6.8 or later

Affected products

ProductAffected versionsFixed in
barryvdh/laravel-translation-managerPackagistv < 0.6.80.6.8

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.