CVE-2025-49147
Description
Umbraco, a free and open source .NET content management system, has a vulnerability in versions 10.0.0 through 10.8.10 and 13.0.0 through 13.9.1. Via a request to an anonymously authenticated endpoint it's possible to retrieve information about the configured password requirements. The information available is limited but would perhaps give some additional detail useful for someone attempting to brute force derive a user's password. This information was not exposed in Umbraco 7 or 8, nor in 14 or higher versions. The vulnerability is patched in versions 10.8.11 and 13.9.2.
How to fix
- umbraco umbraco_cms10.8.11, 13.9.2 or later
- Umbraco.Cms10.8.11, 13.9.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| umbraco umbraco_cms | 10.0.0 ≤ v < 10.8.11, 13.0.0 ≤ v < 13.9.2 | 10.8.11, 13.9.2 |
| Umbraco.CmsNuGet | 10.0.0 ≤ v < 10.8.11, 13.0.0 ≤ v < 13.9.2 | 10.8.11, 13.9.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.