CVE-2025-4919

High

Description

An attacker was able to perform an out-of-bounds read or write on a JavaScript object by confusing array index sizes. This vulnerability was fixed in Firefox 138.0.4, Firefox ESR 128.10.1, Firefox ESR 115.23.1, Thunderbird 128.10.2, and Thunderbird 138.0.2.

SeverityHigh
CVSS8.8
Exploit probability—
ProductMozilla Firefox
PublishedMay 17, 2025
First seenMay 17, 2025

How to fix

Update
  • mozilla firefox115.23.1, 138.0.4, 128.10.1 or later
  • mozilla thunderbird128.10.2, 138.0.2 or later

Affected products

ProductAffected versionsFixed in
mozilla firefoxv < 115.23.1, v < 138.0.4, 116.0 ≤ v < 128.10.1115.23.1, 138.0.4, 128.10.1
mozilla thunderbirdv < 128.10.2, 138.0 ≤ v < 138.0.2128.10.2, 138.0.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.