CVE-2025-49812
High
Description
In some mod_ssl configurations on Apache HTTP Server versions through to 2.4.63, an HTTP desynchronisation attack allows a man-in-the-middle attacker to hijack an HTTP session via a TLS upgrade. Only configurations using "SSLEngine optional" to enable TLS upgrades are affected. Users are recommended to upgrade to version 2.4.64, which removes support for TLS upgrade.
SeverityHigh
CVSS7.4
Exploit probability—
Product
Apache Http Server
PublishedJul 10, 2025
First seenJul 10, 2025
Weakness typeCWE-287Improper authentication
How to fix
Update
- apache http_server2.4.64 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache http_server | v < 2.4.64 | 2.4.64 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.