CVE-2025-49845

High

Description

Discourse is an open-source discussion platform. The visibility of posts typed `whisper` is controlled via the `whispers_allowed_groups` site setting. Only users that belong to groups specified in the site setting are allowed to view posts typed `whisper`. However, it has been discovered that users of versions prior to 3.4.6 on the `stable` branch and prior to 3.5.0.beta8-dev on the `tests-passed` branch can continue to see their own whispers even after losing visibility of posts typed `whisper`. This issue is patched in versions 3.4.6 and 3.5.0.beta8-dev. No known workarounds are available.

SeverityHigh
CVSS7.5
Exploit probability—
ProductDiscourse
PublishedJun 25, 2025
First seenJun 25, 2025

How to fix

Update
  • discourse discourse3.4.6 or later

Affected products

ProductAffected versionsFixed in
discourse discoursev < 3.4.63.4.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2025-49845 · Discourse · Dark Radar