CVE-2025-50151
High
Description
File access paths in configuration files uploaded by users with administrator access are not validated. This issue affects Apache Jena version up to 5.4.0. Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.
SeverityHigh
CVSS8.8
Exploit probability—
Product
Apache Jena
PublishedJul 21, 2025
First seenJul 21, 2025
Weakness typeCWE-20Improper input validation
How to fix
Update
- apache jena5.5.0 or later
- org.apache.jena:jena5.5.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache jena | v < 5.5.0 | 5.5.0 |
| org.apache.jena:jenaMaven | v < 5.5.0 | 5.5.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.