CVE-2025-50505
High
Description
Clash Verge Rev thru 2.2.3 (fixed in 2.3.0) forces the installation of system services(clash-verge-service) by default and exposes key functions through the unauthorized HTTP API `/start_clash`, allowing local users to submit arbitrary bin_path parameters and pass them directly to the service process for execution, resulting in local privilege escalation.
SeverityHigh
CVSS7.8
Exploit probability—
ProductClash Verge Rev
PublishedOct 7, 2025
First seenOct 7, 2025
Weakness typeCWE-250CWE-250
How to fix
Update
- Clash Verge Rev2.3.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| Clash Verge Rev | v ≤ 2.2.3 | 2.3.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.