CVE-2025-5175

Medium

Description

A vulnerability was found in erdogant pypickle up to 1.1.5. It has been classified as critical. This affects the function Save of the file pypickle/pypickle.py. The manipulation leads to improper authorization. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.0 is able to address this issue. The patch is named 14b4cae704a0bb4eb6723e238f25382d847a1917. It is recommended to upgrade the affected component.

SeverityMedium
CVSS5.3
Exploit probability—
ProductErdogant Pypickle
PublishedMay 26, 2025
First seenMay 26, 2025

How to fix

Affected products

ProductAffected versionsFixed in
erdogant pypicklev < 2.0.02.0.0
pypicklePyPIv < 2.0.02.0.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.