CVE-2025-5196

Medium

Description

A vulnerability has been found in Wing FTP Server up to 7.4.3 and classified as critical. Affected by this vulnerability is an unknown functionality of the component Lua Admin Console. The manipulation leads to execution with unnecessary privileges. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 7.4.4 is able to address this issue. It is recommended to upgrade the affected component. The vendor explains: "[W]e do not consider it as a security vulnerability, because the system admin in WingFTP has full permissions [...], but you can suggest the user run WingFTP service as Normal User rather than SYSTEM/Root, it will be safer."

SeverityMedium
CVSS6.6
Exploit probability—
ProductWftpserver Wing Ftp Server
PublishedMay 26, 2025
First seenMay 26, 2025
Weakness typeCWE-250CWE-250

How to fix

Update
  • wftpserver wing_ftp_server7.4.4 or later

Affected products

ProductAffected versionsFixed in
wftpserver wing_ftp_serverv < 7.4.47.4.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.