CVE-2025-52434

High

Description

Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') vulnerability in Apache Tomcat when using the APR/Native connector. This was particularly noticeable with client initiated closes of HTTP/2 connections. This issue affects Apache Tomcat: from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 9.0.107, which fixes the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Tomcat
PublishedJul 10, 2025
First seenJul 10, 2025

How to fix

Update
  • apache tomcat9.0.107 or later
  • org.apache.tomcat:tomcat-coyote9.0.107 or later
  • org.apache.tomcat.embed:tomcat-embed-core9.0.107 or later

Affected products

ProductAffected versionsFixed in
apache tomcat9.0.0 ≤ v < 9.0.1079.0.107
org.apache.tomcat:tomcat-coyoteMaven9.0.0.M1 ≤ v < 9.0.107, 8.5.0 ≤ v ≤ 8.5.1009.0.107
org.apache.tomcat.embed:tomcat-embed-coreMaven9.0.0.M1 ≤ v < 9.0.107, 8.5.0 ≤ v ≤ 8.5.1009.0.107

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.