CVE-2025-52552

Medium

Description

FastGPT is an AI Agent building platform. Prior to version 4.9.12, the LastRoute Parameter on login page is vulnerable to open redirect and DOM-based XSS. Improper validation and lack of sanitization of this parameter allows attackers execute malicious JavaScript or redirect them to attacker-controlled sites. This issue has been patched in version 4.9.12.

SeverityMedium
CVSS6.1
Exploit probability—
ProductFastgpt
PublishedJun 21, 2025
First seenJun 21, 2025

How to fix

Update
  • fastgpt fastgpt4.9.12 or later

Affected products

ProductAffected versionsFixed in
fastgpt fastgptv < 4.9.124.9.12

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.