CVE-2025-52896
Medium
Description
Frappe is a full-stack web application framework. Prior to versions 14.94.2 and 15.57.0, authenticated users could upload carefully crafted malicious files via Data Import, leading to cross-site scripting (XSS). This issue has been patched in versions 14.94.2 and 15.57.0. There are no workarounds for this issue other than upgrading.
SeverityMedium
CVSS5.4
Exploit probability—
Product
Frappe
PublishedJun 30, 2025
First seenJun 30, 2025
Weakness typeCWE-79Cross-site scripting (XSS)
How to fix
Update
- frappe frappe14.94.2, 15.57.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| frappe frappe | v < 14.94.2, 15.0.0 ≤ v < 15.57.0 | 14.94.2, 15.57.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.